terça-feira, 4 de agosto de 2009

Ubuntu Linux apresenta vulnerabilidades

A Canonical anunciou um update para o kernel para as versões 6.06 LTS, 8.04 LTS, 8.10 e 9.04 de seu sistema operacional Ubuntu.

Ao todo, são quatro patches que devem corrigir falhas de segurança graves nos pacotes do kernel. Segundo a organização, os problemas foram encontradas por diversos hackers que enviaram mensagens avisando sobre as vulnerabilidades.

A recomendação é que os usuários façam o update das distribuições o quanto antes, incluindo as variações Kubuntu, Edubuntu e Xubuntu. Após a instalação, a máquina deverá ser reiniciada para que tudo funcione corretamente.

Entre os problemas, uma falha no driver de rede pode permitir ataques remotos que podem derrubar o sistema ou garantir que o invasor ganhe privilégios de administrador. Apesar de atacarem áreas diferentes, todos os bugs permitem níveis similares de controle do sistema.

Para fazer a correção, os administradores deverão procurar os seguintes pacotes de kernel:

6.06 LTS para linux-image-2.6.15-54.78
8.04 LTS paralinux-image-2.6.24-24.57
8.10 para linux-image-2.6.27-14.37
9.04 para linux-image-2.6.28-14.47

Por questões de compatibilidade, após a instalação dos updates, alguns programas podem não funcionar mais. A empresa ainda avisa que todos os pacotes de terceiros que foram instalados no sistema devem ser recompilados para que tudo volte ao normal.

Nenhum comentário: